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ABSTRACT 

 

The offshore structural design practice in Malaysia only focus more on wind and wave 

effects analysis rather than seismic effect. At the east of Malaysia, the Philippine plate 

moves westward with an estimate velocity of 80mm/year and cause micro faults in 

Sabah. Thus, this thesis develops the earthquake ground motion due to Philippine 

earthquake for assessment of offshore platform in Malaysia. Besides, the adequacy of 

existing design of offshore platform in Malaysia is determined when subjected to 

earthquake loading. The analysis of behavior of the offshore platform structures of 3-

legged fixed offshore structures under the earthquake effect is obtained to develop the 

earthquake design criteria for the offshore structures that are located in Malaysia region. 

The assessment of fixed offshore structure also covers the static and dynamic for the 

earthquake analysis by using the code of practice of “Recommended Practice for 

Planning, Designing and Constructing Fixed Offshore Platforms (API RP-2A, 2000). As 

for designing the offshore platform, this analysis is considering the dead load, live load, 

environmental loads (wind, wave and current load) and earthquake load such that free 

vibration, time history and response spectrum. The SAP 2000 computer program has 

been used to check the steel structure based on Eurocode 3, 2005. The most critical 

member of jacket offshore platform for the analysis of the various load also determined 

by compared the element capacity with manual calculation.  However, there are 

assumption has been made such that the structure is fixed to the ground and the 

geometry, material properties and section properties of the structure are represent 

almost the same from the actual structure. 
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ABSTRAK 

 

Amalan reka bentuk struktur luar pesisir di Malaysia hanya memberi tumpuan lebih 

kepada analisis angin dan gelombang berbanding daripada kesan seismik. Di timur 

Malaysia, plat Filipina bergerak ke arah barat dengan anggaran halaju 80mm/tahun dan 

menyebabkan kerosakan mikro di Sabah. Oleh itu, tesis ini membentangkan 

penyelidikan gerakan gempa bumi akibat gempa bumi di Filipina untuk penilaian 

platform luar pesisir di Malaysia. Selain itu, kecukupan reka bentuk sedia ada platform 

luar pesisir di Malaysia ditentukan apabila dikenakan beban gempa bumi. Analisis 

kelakuan struktur platform luar pesisir berkaki 3 tetap di bawah kesan gempa bumi bagi 

membangunkan kriteria reka bentuk gempa bumi untuk struktur luar pesisir yang 

terletak di rantau Malaysia. Penilaian struktur luar pesisir tetap juga meliputi statik dan 

dinamik untuk analisis gempa bumi dengan menggunakan kod amalan "Cadangan 

Amalan Perancangan, Merekabentuk dan Membina Platform Luar Pesisir Tetap (API 

RP-2A, 2000). Bagi mereka bentuk platform luar pesisir, analisis ini menitikberatkan 

beban mati, beban hidup, beban alam sekitar (angin, ombak dan beban arus) dan beban 

gempa bumi seperti getaran bebas, sejarah masa dan analisis tindak balas spektrum. 

SAP 2000 merupakan program komputer yang telah digunakan untuk memeriksa 

struktur besi keluli berdasarkan Eurocode 3, 2005. Elemen platform luar pesisir jaket 

yang paling kritikal dianalisis dengan pelbagai beban yang ditentukan oleh kapasiti 

elemen yang dibenarkan dengan pengiraan manual. Walau bagaimanapun, terdapat 

beberapa andaian telah dibuat seperti struktur adalah tetap pada tanah dan geometri, 

sifat bahan dan sifat-sifat struktur yang memberi gambaran hampir sama dengan 

struktur sebenar. 
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CHAPTER 1 

 

 

INTRODUCTION 

 

 

1.1 BACKGROUND 

 

 Most of the structural building in Malaysia is designed without considering of the 

earthquake effects such as Petronas Twin Tower (KLCC), KOMTAR Tower, Berjaya 

Times Square Tower and also offshore structure. There are no regulations requiring the tall 

building to be designed for earthquake in Malaysia as Malaysia does not lie in any 

presently demarcated seismic zone. However, Malaysia is located close to two most 

seismically active plate boundaries which are inter-plate boundary between Indo-Australian 

Plates and Eurasian Plates on the west and also the inter-plate boundary between Eurasian 

and Philippine Plates on the east (Husen, et al., 2013). These plates undergo many small 

movements against each other by time to time. The plates can slide horizontally against 

each other or pull away from each other or can be it coming towards each other causing one 

plate to dive beneath the other as in Figure 1. 
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Figure 1.1: Types of plate’s movement  

 

Source: Ir Ng Pek Har, Hadi Golabi (2005) 

 

The movements of involving large plates can cause the sudden movement that will 

results the huge energy to be released in the form of waves. These waves will travel inside 

the earth and along the ground which are felt by us as shakes and tremors. This is called an 

earthquake. The intersecting edges of the plates are called faults. Therefore, an earthquake 

is happen once there are both abrupt slide on a fault, causing earth trembling and emitted 

seismic vitality affected by the slide or through volcanic or magmatic movement or further 

unexpected pressure adjustments in the ground.  

 

The tremor affects endangers such as ground shaking, liquefaction, surface faults, 

landslide, tsunami and also tectonic deformations. These all types of hazards depend on the 

geographical location, ground conditions and amount of tectonic activity along the faults.  

Geotechnical factors often exert a main influence on destruction patterns and loss of life in 

earthquake events (Aminaton Marto, et al., 2011).  Along the transmission during seismic 

waves, the resonance effect would cause amplification behavior during upward 

propagation. The amplified waves make possible the soil liquefaction to be happens within 

the region (Marto, n.d., 2014). The impact and damage due to tsunami depends on some 

factors such as wave speed and height which are their coastal topography areas and also 

debris that carried by water (Ghobarah, et al., 2006). 
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Microzonation is the Mapping of seismic hazard at local scales to incorporate the 

effects of local geotechnical factors (Aminaton Marto, et al., 2011). At the east of Malaysia, 

the Philippine plate moves westward with an estimate velocity of 80mm/year and cause 

micro faults in Sabah (Mohd Rosaidi bin Che Abas, 2001). Sabah is the only state in 

Malaysia that exposed to earthquake activities if compared to other parts of Malaysia. 

 

 

 

 

 

 

 

 

Figure 1.2: The movement of Philippine plate moves westward  

 

Source: Mohd Rosaidi bin Che Abas (2001) 

 

The Peninsular Malaysia, Sabah and Sarawak located just behind the active seismic 

area. Therefore, there is an effort to investigate the behavior of offshore structure to sustain 

earthquake effect. The study is also covering the 3 legs of offshore platform and by using 

the software of SAP 2000 to make a model for offshore structure. 
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1.2  PROBLEM STATEMENT 

 

Nowadays, the offshore structural design practice in Malaysia only focus more on 

wind and wave effects analysis rather than seismic effect. We cannot guarantee others that 

our offshore platform is safe for earthquake effects. This is because the wind loads damage 

the structure by externally applied pressures, while earthquake damage is caused by 

internally generated inertial forces induced by vibration of the structure’s mass. 

 

Our country, Malaysia has to worry about the earthquake effects. Year by year, our 

neighboring tectonic plates which are Indian plate, the Australian plate, the Eurasian plate 

and the Philippine plates are moving and pushing our country. Eastern Sabah is prone to 

trembles affected by tremors in the Southern Philippines. In 1976, one of the worst 

earthquakes that happened when a reading of Richter scale is 5.8 of their magnitude 

temblor Lahad Datu, Sabah. The highest observed intensity in Lahad Datu and Kunak was 

assessed of about VII on MM scale. 

 

 

 

 

 

 

 

 

Figure 1.3: Major tectonic plates around Malaysia 

 

Source: Mohd Rosaidi bin Che Abas (2001) 



5 
 

Furthermore, Sarawak also impaired by prolonged distance of tremor that started 

from the Straits of Macassar, Celebes Sea and  Sulu Sea of the West of Philippine. The 

highest perceived Mercalli Intensity at Sarawak was estimated of about V on MM scale 

which produced by this distant earthquake. We are lucky that the earthquake effect does not 

cause much impact to our country. However, we must always be in precaution mode and 

get well prepared for the possibility of adversity earthquake occur and also damage of our 

structures. Thus, this research study will demonstrate the behavior of our offshore 

structures for 3 legs under earthquake effect. The offshore structure modelling analysis was 

using the computer software of SAP 2000. 

 

1.3  RESEARCH OBJECTIVES 

 

The main objective of this research is to estimate the earthquake ground motion due 

to Philippine earthquake for assessment of offshore platform in Malaysia, while the sub 

objectives of this research are:- 

 

1.      To determine the adequacy of existing design of offshore platform in Malaysia when 

subjected to earthquake loading. 

 

 2.  To determine the earthquake design criteria for offshore platform located in 

Malaysia 
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1.4  SCOPE OF STUDY 

 

1. The case study of the earthquake is around the area of Philippine and their effect to 

Malaysia. 

 

2. The type of offshore used will be 3-legged fixed offshore platform. 

 

3. Study the architectural drawing of a typical 3-legged jacket of fixed offshore 

platform 

 

4. Analyze the data that provided from Malaysia Meteorology Department (MMD). 

 

5. The computer software for offshore structure modelling analysis is SAP 2000. 

 

1.5 RESEARCH SIGNIFICANCE 

 

 The significance of the research study is to identify the earthquake ground motion 

due to Philippine earthquake for assessment of offshore platform in Malaysia. Another 

purpose of this research study are to determine the adequacy of existing design of offshore 

platform in Malaysia when subjected to earthquake loading and also determine the 

earthquake design criteria for offshore platform located in Malaysia. The analysis of 

behavior of the offshore platform structures of 3-legged fixed offshore structures under the 

earthquake effect is obtained to develop the earthquake design criteria for the offshore 

structures that are located in Malaysia region. A hundreds of thousands of people could be 

saved if the structures are considering the earthquake effect by built it to withstand the 

shaking from the passage of seismic waves. 



 

 

 

CHAPTER 2 

 

 

LITERATURE REVIEW 

 

 

2.1  EARTHQUAKE 

 

Earthquake is one of the most destructive natural hazards that can cause many 

deaths. An earthquake happens when there is a sudden release of energy causes the ground 

to shake and vibrate, associated with passage of waves of energy that been released at its 

sources. Earthquakes sometimes can kill till hundreds of thousands of people and leveling 

entire town or cities just in a few minutes or seconds. The earthquake causes the secondary 

hazards such as shaking, landslides, tsunamis and liquefaction. Our earth is divided into 

about twelve large tectonic plates and there are moving relative to other. There are also 

many other smaller plates. Commonly, the earthquakes in the world occurs when two of 

these plates meet and then moving past each other.  
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Figure 2.1: Earth map that showing the major divergent, convergent and  transform plate 

boundaries and outlines of the continents  

 

Source: Timothy Kusky (2008). 

 

An earthquake originates from one place and later spreads out in all directions 

throughout the fault plane. The point in the Earth is called focus where the earthquake 

energy is released first and that will represents the area on one side of a fault that in fact 

moves relatively to the rocks on the other side of fault plane. While, the Earth’s surface that 

lies through vertically above the focus is called epicenter. An earthquake can causes the 

significant defects and damages within 100-200km radius from the epicenter.  

 

Even though Peninsular Malaysia is located in the stable Sunda Shelf and with low 

to medium seismic activity level, sometimes tremors can be felt from the large earthquakes 

that originated from the intersection areas of Eurasian plate and Indo-Australian plate near 
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Sumatra (Azlan Adnan, et al., 2005). The tremors that have been occurred can cause panic 

to the public people of several cities in Peninsular Malaysia which are Kuala Lumpur and 

Penang as for example, cases that have been reported on 2
nd

 November 2002 which is the 

cracks on buildings in Penang due to earthquake. (Azlan Adnan, et al., 2005). While 

recently, in Kota Kinabalu, a mild earthquake, with a magnitude of 4.4 on the Richter scale, 

was recorded in Pulau Banggi, Kudat on October 24, 2014 (The Star Online, 2014) 

 

 

 

Figure 2.2: Mechanism of Earthquake 

 

Source: Ir Ng Pek Har, Hadi Golabi (2005) 

 

2.2 SEISMIC WAVE 

 

As the big earthquake occurs, the surface of the Earth then eventually forms into 

waves that move throughout the surface, just as in the ocean. These waves can cause 
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extremely destructive or also can be pretty spectacular. These seismic waves’ moves of all 

directions just like ripples or sound waves that been formed or moved across the water as a 

stone is thrown in a still pond. The ground will returns to its original shape just after the 

seismic waves have passed through the ground, meanwhile the structures of building or 

others things being destroyed. The people who have experienced the large earthquakes 

happens eventually seen waves of rock with several feet high that being moving toward 

them at very high speeds. 

 

There are three types of seismic waves which are:- 

 

1. Body waves  

 

2. Surface waves 

 

3.  Rayleigh waves 

  

The body waves are the seismic waves that can either radiate underground from the 

focus. While the surface waves are the seismic waves that can either radiate aboveground 

from the epicenter. In addition, the body waves travel throughout the whole body of the 

Earth and also move faster than surface waves. Surface waves will cause most of the 

destructive due to earthquakes as compared to body waves because as they pass, they 

actually change the shape of the surface of the Earth. 
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Figure 2.3: Analogy to seismic waves using slinky waves and ropes 

 

Source: Ir Ng Pek Har, Hadi Golabi (2005) 
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2.2.1 Body Waves 

 

Body waves are consists of two types which are:- 

 

1. P waves (Primary or compressional waves) 

 

2. S waves (Secondary or shear waves) 

 

P waves will deform material through a change in density and volume and also can 

pass through three states which are solids, liquids and gases. P waves is moves with high 

velocity that is about 3.5-4 miles per second (6km/sec) and this type of waves is the first to 

be recorded by seismographs. Therefore, they are called primary waves or P waves. P 

waves gives the effects to a lot damage as they temporarily change the volume and area of 

ground that humans have built things and that requires the ground to keep its original 

shape, volume and their area. As the ground suddenly changes its volume by contracting or 

expanding, will cause the construction breaks. 

 

S waves are the second kind of body waves which are known as shear waves or 

secondary waves because they only change the shape of material but not of its volume. 

Shear waves only can be transmitted throughout the solids, whereas liquids cannot do so. S 

waves can move material at right angles to the direction of wave travel; hence they have an 

alternating series of sideways motion. S waves moves with the velocity of two miles per 

second (3.5km/sec). S waves only may be able to knock the buildings off foundation when 

they pass. 
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2.2.2 Surface Waves 

 

 Surface waves can cause the extremely destructive due to earthquake. This is 

because of their complicated types of twisting and also circular motions as for example the 

circular motions waves out past the surf zone of the beach. Surface waves are travel much 

slower than body waves. However, it causes the most damages due to its types of 

complicated types of motion.  

 

2.2.3 Rayleigh waves 

 

Others third type of wave is called Rayleigh which been introduced by Lord 

Rayleigh (1855). It is generated by the interaction of P and S waves; however have the 

different characteristics from P and S waves. Their particle motion at the surface is a 

retrograde ellipse that includes both horizontal and vertical. Rayleigh waves are the 

frequency-dependent penetration of the particle motions as it happens within a depth of 

about one wavelength. Thus, the changes in frequency or wavelength will affect the 

penetration depth of surface wave motions below of the ground surface. 
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Figure 2.4: Particle motions of body and surface wave propagation  

 

Source: Ir Ng Pek Har, Hadi Golabi (2005) 

 

2.3 MEASURING EARTHQUAKE 

 

 Seismographs are devices which are built to measure the amount and direction of 

shaking due to earthquakes. The method to measure the shaking of the Earth is by the point 

of reference must be free from shaking and ideally on a hovering platform. Since the 



15 
 

hovering platform is impractical, therefore the instrument of inertial seismograph is 

designed. The inertial seismograph is been used by the ink-filled stylus is attached to the 

heavy weight then remain constant during an earthquake. Then, the continuously turning 

graph paper been attached to the ground, moves back and forth during the quake, will be 

results the zigzag trace of the record of the earthquake motion on the graph paper. Some of 

the seismographs are set up as pendulums and also some others as springs to get the 

measurement of the ground motion in many directions.  

 

 

 

Figure 2.5: Seismograph to measure the ground motion due to earthquake  

 

Source: Professor Stephen A. Nelson (2005) 
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Figure 2.6: Seismographs results the seismogram 

 

Source: Ir Ng Pek Har, Hadi Golabi (2005) 
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2.4 EARTHQUAKE MAGNITUDE 

 

 Ritcher Scale is used to measure earthquake magnitude based on how high the 

amplitude of seismic waves which in range of 100km (62miles) from the epicenter. As 

seismograph produce a zigzag trace for ritcher scale magnitude. While in the microzonation 

seismic mapping, use ‘gals’ that represents to the acceleration faced in a ground motion  

because of the seismic effect from a certain distance away from the epicenter which is 

1000gals = 1g = 9.81 m/s
2 

(Engr. Dr. Jeffrey Chiang, Engr. M. C. Hee, 2008). Earthquake 

magnitude can be defined as follows:- 

 

𝑀 = log
𝐴

𝐴0 
 

 

Where,  

 

A = Peak amplitude in seismogram which in distance of 100km from epicenter (μm) 

 

A0 = Zero-magnitude earthquake of a peak amplitude which is 1μm for 100km 

 

Before the development of using seismograph, it is measured by use modified Mercalli 

intensity scale. It is measured by referring the way of the people reacts with earthquake and 

their assessment of the damage or destructiveness of the building due to earthquake 

(Roberto Villaverde, 2009). This Mercalli intensity is not really accurate as compared to 

Ritcher Scale because it is not corrected for the distance from epicenter. The comparison of 

Mercalli intensity with the Richter magnitude as shown in table 2.0. 

 

 

 

 

 

 

(2.1) 
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Table 2.1: Modified mercalli intensity scale compared to ritcher magnitude  

 

MERCALLI 

INTENSITY 

RICHTER 

MAGNITUDE 

DESCRIPTION 

I-II <2 Not sensed by most people 

III 3 Sense by some people indoors, especially on high 

floors. 

IV-V 4 Perceived by some people. Dangling objects 

swing, dishes rattle. 

VI-VII 5 All people feel. Some building destruction (esp. to 

masonry), waves on fishponds. 

VII-VIII 6 Difficult to stand, people scared or panicked. 

Difficult to steers cars. Moderate damage to 

buildings. 

IX-X 7 Major damage, general panic of community. Most 

masonry and frame structures ruined. 

Underground pipes fractured. Large landslides. 

XI-XII 8 and higher Near total damaged. 

 

 

Source: Timothy Kusky (2008) 

 

2.5 OFFSHORE STRUCTURE 

 

2.5.1 Introduction 

 

 Nowadays, offshore structures are widely used all around the world especially for 

oil and gas industry which includes oil exploration and production. The exploration and 

extraction is the oils which are lying very deep to the bottom of sea, from earth’s crust. The 

structure of offshore structures can be steel structure and also concrete structure. The steel 
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used are from various grades such as from mild to high strength steel. As for selection for 

type of steel platform, it depends on the water depth and also their purpose.  

 

 The offshore structures are very important and really useful in the continuing for the 

production of oils. The offshore structures have their big roles in make sure our life to be 

ease as assuring the oil to be supplied. Therefore, the design criteria for the offshore 

structure must be concerned as to be function safely for a long times and due to the 

challenges of marine environment. The design must be considering of the waves, wind, 

strong current due to loads and last but not least the earthquake loading. The most 

important is when the safety design of a bottom-mounted offshore platform located in a 

seismic zone, the effect of earthquakes on structural response must be carefully examined 

so that the facilities can retain appropriate seismic resistance (Park, Koo, & Kawano, 2011). 

 

 Seismic consideration covers the inspection of the subsurface soils at the platform 

site for instability because of liquefaction, submarine slides caused by earthquake activity, 

proximity of the site to faults, the features of the ground motion expected throughout the 

life of the platform, and the acceptable seismic risk for the type of operation intended. 

(Edition, 2007) 

 

 

 

 

 

 

Figure 2.7: Offshore Model 
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2.5.2 Type of Offshore Structures 

 

1. Fixed Platform 

 

2. Concrete Gravity Structure 

 

3. Compliant Towers 

 

4. Tension Leg Platform 

 

5. Floating Production Systems 

 

6. Subsea systems 

 

7. SPAR Platforms 

 

 

 

 

 

 

 

 

Figure 2.8: Types of offshore platform 

 

Source: Kabir Sadeghi (2007) 
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 The selection of offshore platforms is depending on depth of water and their 

application. Nowadays, jacket fixed platform is been used 95% of the offshore platform, 

around the world. It is suitable in the shallow water and are the most stable structures 

because their “leg” or steel is constructed extending directly down to the sea floor. 

Therefore, their benefits such there is a constraint in exposure to the water and wind forces. 

Steel tubular structure or jacket having its feet on the sea floor supports the deck and their 

platform is fixed.  

 

2.5.3 Design Consideration of Offshore Platform 

 

 Offshore platform normally used the type of platform which made of steel at Gulf 

of Mexico in the exploration and production of oil (Sadeghi, 2001).  The design and 

analysis of offshore platform must be concerned of many factors such as follows:- 

 

1. Soil characteristics.  

 

2. Environmental issues that include tides, ice, winds, currents, shallow gases, marine 

growth and earthquakes (Sadeghi, 2001). 

 

3. Code necessities of the American Institute of Steel Construction “AISC” codes  

 

4. Follows the practice of “Recommended Practice for Planning, Designing and 

Constructing Fixed Offshore Platforms (API RP-2A, 2000). 

 

API practices require the assessment of seismic activities and for area in low seismic 

action to design offshore platform. It also states such that the lowest deck should preserve 

at least 1.5m air gap linking the base of the deck beams and the wave peak throughout the 
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highest estimated level of water considering for the merges of wave peak and tides. Their 

minimum design principles are for 100 year design of storm.  

 

As for designing the offshore platform, it needs to consider the dead load, live load and 

environmental loads. The dead loads are the permanent equipment or the structures that do 

not alter the form of operation and the weights of their platform structure itself. Whereas 

for the live loads are the loads that been forced on the platform while a mode of operation 

or else from one mode of operation to one another. The environmental loads are the loads 

which been forced on the platform by the natural phenomena such as wind, waves, current, 

earthquake and etc. The platform must withstand all the loads that are generated to make 

sure their structures to be safe. 

 

2.5.4 Current Malaysia Practice of Seismic Design 

 

Nowadays, structural design in Malaysia has still not considering earthquake and 

hurricane loading (Potty, Redzuan, & Hamid, 2013). It is an intention to implement the 

Eurocode 8 on seismic design as this standard code are based on the two international 

design codes for seismic actions that were cited as references which are Eurocode 8 and the 

American-based IBC 2000 (Engr. Dr. Jeffrey Chiang, Engr. M. C. Hee, 2008).  

 

2.5.5 Analysis of Offshore Platform 

 

 Based on American Petroleum Institute’s proposed the practice that states under 

seismic loading might be use computing structural response of response spectrum or time 

history analysis for planning, designing and constructing of offshore platforms. The 

structures may undergo vibrations by earth waves of short wavelength from nearby source 
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earthquakes or through vibrations stimulated from near strong vibration sources (Mohamed 

I.S.Elmasry, 2012). Therefore, the offshore structure used the dynamic response analysis 

which is the combination between live load and dead load together. In structural reliability 

analyses, the earthquake loads commonly been modeled as random processes or time 

histories (Moustafa & Mahadevan, 2011).  

 

There are three methods need to be used in the analysis of the offshore platform such as 

follows:- 

 

1. Free Vibration Analysis 

 

2. Response Spectrum 

 

3. Time history Analysis 

 

As for design response spectrum, the structures are applicable for time history analysis 

and the ground acceleration data should be scale by the factor of G factor. The 

consideration of geometrical nonlinearity through base mat uplift is the method of time 

history nonlinear earthquake response analysis method that was proposed by Tanaka et al. 

(1995) and Momma et al. (1995) which are the interaction between horizontal and vertical 

motion to be considered (Kobayashi, et al. , 2002). 

 

2.6 SAP 2000 PROGRAM 

 

SAP name can be testified is the art of analytical and structural program for the 

design and analysis of civil structures. Their featuring are very advanced, sophisticated, 
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versatile consumer with interface operated by design tools that really fast and perfect 

construction models for engineer to finish up the most complex projects. 

 

SAP is the object based which gives the significance of the models is formed using 

members that characterize the physical reality. Then, the complex models can be produced 

and suited with powerful that formed in templates. Their integrated code characters would 

automatically produces wave, wind, seismic loads with inclusive automatic steel and also 

international design standards. It also allows analytical techniques with step by step with 

nonlinear analyses which would be static or nonlinear of time history dynamic analysis. 

 

From an unsophisticated small 2D static frame analysis transforms to a great 

complex 3D nonlinear dynamic analysis. The software of SAP 2000 is the simplest, most 

helpful, practical solution for the design and structural analysis. 

 

 

 

 

 

 

 

 

 

Figure 2.9: SAP 2000 Program (Version 15) 

 



 

 

 

CHAPTER 3 

 

 

METHODOLOGY 

 

 

3.1  INTRODUCTION 

 

 In order to make sure the project successful, the planning and scheduling are 

arranged as follows:- 

 

 

 

Figure 3.1: Flow chart of planning and scheduling 
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3.2  LITERATURE REVIEW 

 

 During this phase, all the information, data, studies and facts that related to the 

project are been collected. The data collecting process is focused on the major topics of this 

project such as follows:- 

 

1. Earthquake 

 

2. Seismic Wave 

 

3. Measuring Earthquake 

 

4. Earthquake Magnitude 

 

5. Offshore Platform 

 

6. SAP 2000 Program 

 

3.3  GATHER THE INFORMATION AND DATA 

 

 During this stage, as to make sure the projects is going smoothly, the further 

information and data for the modelling and analysis work need to be carried out. The 

information and data that required are as follows:- 

 

1. Location of the case study of the offshore platform. 
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2. Drawing of the offshore platform. 

 

3. Background of the offshore platform. 

 

4. Type of the offshore platform and their legs. 

 

5. Material used for the structure of the offshore platform. 

 

6. Limitation of the offshore platform. 

 

 

 

 

 

 

 

 

 

Figure 3.2: A Typical 3-legged Jacket of Fixed Offshore Platform 
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3.4  STEPS IN MICROSOFT EXCEL 

 

The raw data from notepad is inserted to the Microsoft excel to find the maximum value for 

acceleration, velocity and displacement. Besides, from Microsoft excel the graph for HGE, 

HGN and HGZ direction can be obtained. 

 

Step 1: Insert the data to Microsoft excel  

 

i) Insert the raw data from 3 directions of E, N, Z from notepad into Microsoft 

excel. Go to Data > From Text > Browse the location of notepad file > Import 

the file chosen > Click next > Tick space for Delimeters > Next > Click Finish 

 

 

 

 

 

 

 

 

 

Figure 3.3: Import the data to excel 
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Figure 3.4: Tick space for Delimeters and click finish 

 

ii) Choose to locate the data in which row and column > Click Ok. > Arrange the 

title to be in the right column. 

 

 

 

 

 

 

 

 

 

Figure 3.5: Locate the data into Microsoft excel 

 

 

 

 



30 
 

Step 2: Find the maximum value for A (g), V (in/sec), D (in) 

 

i) =MAX((ABS(C3:C214531))). Use command max and abs. Click the first row 

and do colon ( : ), click the last row to select the all the data in that column. 

Press ctrl + shift + enter to do {}, to get the maximum value. 

 

 

 

 

 

 

 

 

 

 

Figure 3.6: Use command max and abs 

 

Table 3.1: The result of the maximum value are obtained 

 

Maximum HGE HGN HGZ 

A (g) 0.001222 -0.00108 0.00096 

V (in/sec) 0.198298 -0.21319 -0.218931 

D (in) -0.140921 0.17486 -0.168419 
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Step 3: Time History graph 

 

i) Click the first row, press ctrl + shift + ↓ to select data for the axis. 

ii) Go to insert, scatter and choose the graph. 

 

 

 

 

 

 

 

 

 

 

Figure 3.7: The maximum value is obtained 

 

 
 

(a) 
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(b) 

 

 

 

(c) 

 

Figure 3.8: Time History graph that  obtained from Microsoft excel.  

                    (a) HGE direction (b) HGN direction (c) HGZ direction. 
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3.5  MODELLING BY AUTOCAD 

 

 

 

Figure 3.9: View A, View B and View C of offshore platform. 

 

 

Figure 3.10: Level 1 and Level 2 of offshore platform. 
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Figure 3.11: Level 3 and Level 4 of offshore platform. 

 

3.6  MODELLING BY SAP 2000 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3.12: 3D view of offshore platform 
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3.6.1 Coordinate System in SAP 2000 Model 

 

Table 3.2: Set of coordinates (a) X grid (b) Y grid (c) Z grid 

 

 

 

A -122.8 

 

1 0 

 

Z0 -992.4 

B 0 

 

2 1869 

 

Z1 0 

C 3118 

 

3 2615 

 

Z2 25200 

D 4355 

 

4 3432 

 

Z2A 35200 

E 5716 

 

5 4539.5 

 

Z3 46200 

F 7572 

 

6 12762 

 

Z4 61200 

G 7943 

 

7 17427 

 

Z4A 62200 

H 8596.5 

 

8 18194 

   I 10155.5 

 

9 19162 

   J 11455 

 

10 20742 

   K 12382.5 

 

11 20984.5 

   L 12907.5 

 

12 22092 

   M 13665 

 

13 23655 

   N 14324 

 

14 25524 

   O 17193 

 

15 25619.5 

   P 19100 

      Q 20062 

      R 20721 

      S 21478 

      T 22003.5 

      U 22931 

      V 24230.5 

      W 25789 

      X 26443 

      Y 26814 

      Z 28670 

      A1 31268 

      B1 34385 

      

(a) (b) (c) 
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.3.7  STEPS IN SAP 2000 

 

Step 1: Begin a new model 

 

Click File menu > New Model. Choose unit set to kN, m, C. Select template for blank. 

 

 

 

Figure 3.13: New model form 

 

Step 2: Insert coordinates value. 

 

Click the Define menu > Coordinate Systems/Grids. In the system area, highlight 

GLOBAL and click Modify/Show System. Insert the coordinates and click OK. 
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Figure 3.14: Coordinates Systems/Grids 

 

Step 3: Define material properties. 

 

Click the Define menu > Materials. Click the Add New Material to display window as 

shown in Figure 3.15. Click OK to close both windows. 

 

 

 

Figure 3.15: Define Materials form 
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Step 4: Define Frame Sections 

 

i) Click the Define menu > Section properties > Frame Sections > Add New 

Property 

 

 

 

Figure 3.16: Define Frame Sections form 

 

ii) Choose Frame Property Type > Steel. Click Steel Section > Pipe 

 

 

 

Figure 3.17: Section Property form 
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iii) Insert the data of the section. 

 

 

 

Figure 3.18: Pipe Section form 

 

Step 5: Draw frame Objects 

 

i) Click the View menu > Set 2D view > Click on the X-Y Plane.  

 

ii) Click the Draw Frame button at the left side. The Properties of Object pop-up 

form will appear as shown in Figure 3.19. 

 

iii) Click in the Section drop-down list on the Properties of Object and choose the 

section of the members. 
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Figure 3.19: X-Y Plane @ Z=0 

 

 

 

 

 

 

 

 

 

 

 

Figure 3.20: Draw Frame Model 
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Step 6: Add Restraints 

 

i) Select three joint at the end of offshore platform. Click on the Assign menu > 

Joints > Restraints 

 

ii) Click on the pinned button. Click OK.  

 

 

 

Figure 3.21: Joint Restraints form 

 

Step 7: Save the Model 

 

i) Click the File menu > Save or Save button to save model. 

 

Step 8: Assign Member End Releases 

 

i) Select the whole of offshore platform in 3D view. Click Assign menu > Frame > 

Releases/partial Fixity. 

 

ii) Tick the Moment 33 (Major) boxes for both Start and End Release. 
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iii) Click OK. 

 

 

 

Figure 3.22: Assign Frame Releases form 

 

Step 9: Define Earthquake Analysis 

 

i) Click Define menu > Function > Response Spectrum >Choose Function Type to 

Add : Eurocode8 1994 > Add New Function 

 

ii) Rename the Function Name : RESPONSE SPECTRUM 

 

iii) Click OK. Refer to Figure 3.23 (a). 

 

iv) Click Define menu > Function > Time History > Add New Function 

 

v) Rename the Function Name 

 

vi) Browse the file location of the data acceleration for each direction.   

 

vii) Click OK. Refer to Figure 3.23 (b). 
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Figure 3.23: (a) Response spectrum settings (b) Time History settings 

 

Step 9: Define Load Cases 

 

i) Click the Define Menu > Load Cases > Add New Load Case > Rename Load 

Case > Choose Load  Case Type > Change Setting for Loads Applied > Click 

OK 

 

      
 

 
(a) (b) 

(a) (b) 
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(c) (d) 

(e) (f) 
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(g) 

 

Figure 3.24: Load settings (a) Response spectrum (b) Time History (c) Dead Load  

         (d) Modal Load (e) Live Load (f) Wind Load (g) Wave Load. 

 

Step 10: Define Load Patterns 

 

i) Click the Define Menu > Load Patterns > Add New Load Pattern > Rename 

Load Pattern Name > Change Type > Auto Lateral Load Pattern 

 

 

 

Figure 3.25: Define Load Patterns Form 
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ii) Click Load Pattern Name (WAVE) > Modify Lateral Load Pattern > Change 

Settings > Vertical Reference Elevation for Wave > Global Z Coordinate of 

Vertical Datum (Offshore Platform Depth) 

 

 
 

Figure 3.26: Wave Load Patterns Settings 

 

iii) Click Current Profile > Add CURRENT > Modify/Show > Change Settings > 

Click OK 

 

 

 

Figure 3.27: Current Profile Data Settings 



47 
 

iv) Click Show Wave Plot > Choose Display Type > Choose Display This item 

 

 

 

Figure 3.28: Contours with Horizontal Wave Velocity 

 

 

 

Figure 3.29: Arrows with Resultant Velocity w/o Current 
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Figure 3.30: Vertical Cut with Horizontal Wave Velocity 

 

 

 

Figure 3.31: Horizontal Cut with Horizontal Wave Velocity 
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Step 11: Assign Loads 

 

i) Click three points at Top Slab as in figure 3.32 > Assign menu > Joint Loads > 

Forces > Choose Load pattern Name > Type value in the Force Global X and Y 

with minus sign which indicates direction of the load downward > Click OK 

 

 

 

Figure 3.32: Click on three points at Top Slab 

 

      

 

 (a) (b) 
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(c) 

 

Figure 3.33: Joint Forces on slab for various load (a) Dead (b) Live (c) Wind  

 

ii) Click points below mean sea level > Assign menu > Joint Loads > Forces > 

Choose Load pattern Name (WAVE) > Choose Direction to test (Type 0.413 in 

the Force Global X) > Click OK 

 

 

 

Figure 3.34: Click points below mean sea level 
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Figure 3.35: Joint Forces for Wave load below mean sea level 

 

 

 

Figure 3.36: Click points above mean sea level 
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Figure 3.37: Joint Forces for Wave load above mean sea level 

 

Step 12: Define Load Combinations 

 

i) Click the Define Menu > Load Combinations > Add New Combo > Rename 

Load Combination Name > Change the settings > Click OK 

 

 

 

Figure 3.38: Load Combination Data Forms 
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Step 13: Run analysis 

 

i) Click the Analyze menu > Run Analysis or click the Run Analysis button  > 

Choose the cases that need to be tested > Click to Run/Do Not Run Case > Run 

Now > Click OK 

 

 

 

Figure 3.39: Set Load Cases to Run Forms 

 

ii) When the analysis is finished, the model is locked.  Lock/Unlocked button 

appears depressed. Locked the model is to prevents any changes to the model. 

When others cases need to be run, unlocked the model first.  

 

Step 14: Review the analysis result 

 

i) Firstly, run the analysis > Display menu > Show Tables > Choose Analysis 

Result that need > Click Joint Output > Displacements > Select Load Cases > 

Click OK 



54 
 

 

 

Figure 3.40: Choose Tables for Display form 

 

ii) Joint Displacements table appears > Click File > Export Current Table > To 

Excel > Click Done to close the tables. 

 

iii) Run the analysis > Display menu > Show Deformed Shape > Select the Case > 

Click OK 

 

 

 

Figure 3.41: Deformed Shape form 
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iv) Run the analysis > Display menu > Show Forces/Stresses > 

Frames/Cables/Tendons >  Select the Case > Select the Component > Click OK 

 

 

 

Figure 3.42: Member Force Diagram for Frames form 

 

v) Right click on the critical members to check for the graph analysis. 

 

3.8  OFFSHORE DESIGN CRITERIA AND PROPERTIES 

 

As for the total stiffness and the total mass of the 3-legged fixed offshore platforms 

structures can be referred to the Appendix C. The total stiffness, k of this model is 

10.5789*10
12

 and its mass is 5125737.7 kg. 
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Table 3.3: Material property data based on Europe EN 1993-1-1 per EN 10025-2 

 

Material type S355 Minimum Yield Stress, Fy 0.355 

Material type Steel Minimum Tensile Stress, Fu 0.51 

Modulus of Elasticity, E 210 Effective Yiled Stress, Fye 0.3905 

Poisson’s Ratio, U 0.3 Effective Tensile Stress, Fue 0.561 

Coefficient of Thermal 

Expansion, A 1.17E-05 Units  Kn,mm,C 

Shear Modulus, G 80.7692     

 

Table 3.4: Self-weight and functional load 

 

No. Load descriptions [MN] 

1 Self-weight -13.306 

2 Jacket appurtenances weight -0.553 

3 Topside dead loads -1.908 

4 Topside live loads -2.655 

5 Piping and equipment weights -29.537 

  Total -47.959 

 

 

Table 3.5: Environmental load 

 

MSL   

Design 

Condition 

62.20m Wave height 10.79 

  Wave period 10.9 

  Current velocity 0.75 

  Wind speed 21.8 

  Max. tide 2 

  Storm surge 0.4 
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3.9 OFFSHORE DESIGN STRUCTURE 

 

All the equations are based on the code of practice of “Recommended Practice for 

Planning, Designing and Constructing Fixed Offshore Platforms (API RP-2A, 2000). All 

the calculations can be referred to Appendix A. 

 

3.9.1 Wind Load 

 

Wind forces are exerted to the portion of the offshore structure platform which is above the 

water such as equipment, deck houses and derricks that are located on the platform (API 

RP-2A, 2000).  

 

𝐹 = (
𝜌

2
) 𝑢2 𝐶𝑠𝐴 

 

Where, 

 

F = wind force (N) 

 

𝜌 = mass density of air (1.2 kg/m
3
) 

 

u = wind speed (m/s) 

 

Cs = shape Coefficient 

 

A = area (m
2
) 

 

(3.1) 
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3.9.2 Wave Load 

 

Waves are irregular in shape, vary in length and height which can approach a platform from 

one or more directions simultaneously. Therefore, it is difficult to determine the intensity 

and distribution of the forces applied by waves. However, the complex nature of the 

technical factors must be considered in developing wave-dependent criteria for the design 

offshore platform structure. The effects of this force exerted by waves can be computed by 

the Morison equation: 

 

𝐹 =  𝐹𝐷 + 𝐹𝐼 =  𝐶𝐷  
𝑤

2𝑔
 𝐴 𝑈 |𝑈| +  𝐶𝑚  

𝑤

𝑔
 𝑉 

𝛿𝑈

𝛿𝑡
  

 

Where, 

 

F = hydrodynamic force vector per unit length acting normal to the axis of the member 

(N/m) 

 

𝐹𝐷= drag force per unit length of the member (N/m) 

 

𝐹𝐼 = Inertia force per unit length of the member (N/m) 

 

𝐶𝐷 = drag coefficient 

 

𝐶𝑚 = inertia coefficient 

 

w = density of water (N/m
3
) 

 

g = gravitational acceleration (m/s
2
) 

 

A = projected area (=D for circular cylinders) (m) 

 

V = displaced volume (=
𝜋𝐷2

4
 for circular cylinders) (m

2
) 

 

U = component of velocity vector due to wave (m/s) 

(3.2) 
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|𝑈| = absolute value of U (m/s) 

 
𝛿𝑈

𝛿𝑡
 = component of local acceleration vector of the water 

 

Table 3.6: Coefficient for wave load 

 

 Cd Cm 

Smooth 0.65 1.6 

Rough 1.05 1.2 

 

3.9.3 Current 

 

Currents are important in the design of the fixed offshore platforms as the forces on the 

platform and it can affect the location and orientation of boat landings and barge bumpers. 

The total current profile should be specified for platform design with associated the sea-

state that produce extreme waves. The current force of the member for no wave conditions 

can be calculated using the equation 3.2 with 
𝛿𝑈

𝛿𝑡
 = 0. 

 

3.10 OFFSHORE DESIGN STRUCTURE FOR CRITICAL MEMBER 

 

All the equations are based on the code of practice of Eurocode 3. All the calculations can 

be referred to Appendix B.   
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3.10.1 Shear Resistance Vc,Rd 

 

Shear resistance, Vc,Rd = Vpl,Rd  

 

𝑉𝑝𝑙,𝑅𝑑 =  
𝐴𝑣  (

𝑓𝑦

√3
)

𝛾𝑚0
 

 

Where,  

 

Av = shear area  

 

fy = yield strength  

 

γm0 = partial factor for resistance of cross-sections whatever the class is (=1) 

 

3.10.2 Shear Stress, 𝝈𝒔 

 

𝜎𝑠 =  
𝑉𝐸𝑑

𝐴𝑐
 

 

Where,  

 

𝑉𝐸𝑑  = design shear stress 

 

Ac = area of section  

(3.3) 

 

(3.4) 
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3.10.3 Allowable Shear Stress, 𝝈𝒂𝒍𝒍,𝒔 

 

𝜎𝑎𝑙𝑙,𝑠 =  
𝑉𝑐,𝑅𝑑

𝐴𝑐
 

 

Where,  

 

Vc,Rd = shear resistance 

 

Ac = area of section  

 

3.10.4 Bending Moment Resistance, Mc,Rd 

 

Moment resistance, Mc,Rd = Mpl,Rd  

 

𝑀𝑝𝑙,𝑅𝑑 =  
𝑊𝑝𝑙 (𝑓𝑦)

𝛾𝑚0
 

 

Where, 

 

Wpl = plastic section modulus 

 

γm0 = partial factor for resistance of cross-sections whatever the class is (=1) 

 

(3.5) 

 

(3.6) 
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3.10.5 Bending Stress, 𝝈𝒃 

 

𝜎𝑏 =  
𝑀𝐸𝑑

𝑆𝑥
  

 

Where, 

 

MEd = design bending moment 

 

Sx = Section modulus 

 

3.10.6 Allowable Bending Stress, 𝝈𝒂𝒍𝒍,𝒃 

 

𝜎𝑎𝑙𝑙,𝑏 =  
𝑀𝑐,𝑅𝑑

𝑆𝑥
 

 

Where, 

 

Mc,Rd = Moment resistance 

 

Sx = Section modulus 

 

(3.7) 

 

(3.8) 

 



 

 

 

CHAPTER 4 

 

 

RESULTS AND DISCUSSIONS 

 

 

4.1  INTRODUCTION 

 

 The 3-legged of fixed offshore structure has been analysed and being assess for the 

seismic analysis. The assessment also covers the static and dynamic for the earthquake 

analysis by using the code of practice of “Recommended Practice for Planning, Designing 

and Constructing Fixed Offshore Platforms (API RP-2A, 2000). The SAP 2000 computer 

program has been used to check the steel structure based on Eurocode 3, 2005.  However, 

there are assumption has been made such that the structure is fixed to the ground and the 

geometry, material properties and section properties of the structure are represent almost 

the same from the actual structure. 

 

4.1.1 Analysis of fixed steel jacket 

 

 As for designing the offshore platform, it needs to consider the dead load, live load, 

environmental loads (wind, wave and current load) and earthquake load such that free 
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vibration, time history and response spectrum. The results that obtained from the various 

loads such as follows: 

 

i. Dead load 

 

ii. Live load 

 

iii. Free Vibration 

 

iv. Response Spectrum 

 

v. Environmental load (wind + wave + current load) 

 

vi. Dead load + Environmental load + Time history 

 

The results that obtained from the analysis as follows: 

 

i. The mode shape of the fixed offshore structure. 

 

ii. The natural period of fixed offshore structure. 

 

iii. The shear force, bending moment, axial force and displacement under various loads. 

 

iv. The maximum shear stress, bending stress and allowable capacity check of the 

members. 
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4.2  ANALYSIS DESIGN CHECK 

 

4.2.1 Free Vibration Analysis 

 

The period of vibration is a basic parameter in the force-based design of structures 

and this parameter describes the spectral acceleration and then the base shear force to which 

the building should be designed. This analysis takes a critical look at the way in where 

seismic design codes around the world have accepted the designer to assume the period of 

vibration to be used in both linear static and dynamic analyses. Then, for the most building 

design projects, empirical building period formulas are need to be used to initiate the design 

process (Kwon O, 2010). The basic period of vibration, T is a function of the stiffness of 

the building mass and the lateral load resisting system.  

 

Many codes identify that the period of vibration from the simplified period–height 

equation is more practical, having been directly gained from the calculated periods of 

vibration of buildings subject to earthquake ground motions, however when higher modes 

are significant (in tall and/or irregular structures) the modal response spectrum method 

gives a more practical profile of the lateral forces (Abdel Raheem SE, 2013) 

 

 

 

Figure 4.1: Free vibration analysis in P-M interaction ratios 
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Table 4.1: Modal Periods And Frequencies 

 

 

 

          
 

 

 

 

Figure 4.2: Deformed shape for (a) mode 1 (b) mode 2 (c) mode 3 (d) mode 4 

 

From the analysis of free vibration cases, the results are obtained for deformed 

shapes that are contains of 12 mode shape with their time period. The most accurate mode 

shape is from mode shape 1, as shown in Figure 4.2 (a), the highest time period is 0.86143 

sec with their frequency of 1.16086 cyc/sec. Figure 4.2 (b) shows for mode 2 which their 

(a) (b) (c) (d) 
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time is 0.72689 sec with frequency of 1.37572 cyc/sec. While, Figure 4.2 (c) shows for 

mode 3 which their time is 0.57422 sec with frequency of 1.74148 cyc/sec. Next, Figure 

4.2 (d) shows for mode 4 which their time is 0.48745 sec with frequency of 2.05150 

cyc/sec. The others 8 mode shapes are shown in the Appendix D. 

 

4.2.2 Response Spectrum Analysis 

 

Response spectrum analysis were obtained by the shape of the target elastic 

acceleration spectrum which are then characterized by the seismic intensity that are 

expressed in terms of the expected design peak ground acceleration (PGA) and also their 

effect of soil ground types (Shehata E. Abdel Raheem, et al., 2014) Many codes recognize 

that a modal response spectrum method gives a more realistic profile of the lateral forces as 

the period-height equation is more realistic.(Crowley H, Pinho R, 2010) There are 

computational advantages by using this method of seismic analysis for prediction of 

displacements and member forces in structural systems. It involves the calculation of only 

the maximum values for the member forces and displacements in each mode using smooth 

design spectra that are the average of several earthquake motions.  

 

 

 

Figure 4.3: Response spectrum analysis in P-M interaction ratios 
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Figure 4.4: Response spectrum graph 

 

From the Figure 4.4, it shows the response spectrum graph. The maximum 

acceleration is 0.675 m/s
2
 and about 0.1022 s to 0.5905 s.  

 

Table 4.2: Response Spectrum Modal Information 

 

 

 

 



69 
 

4.2.3 Time History Analysis (TH Analysis) 

 

Nonlinear time history analysis is the most inclusive method for seismic analysis. 

The earthquake data in the form of acceleration time history is input at the base of structure 

(Kharade AS, et al., 2013). The response of the structure is figured at each second for the 

whole duration of an earthquake. This method different from response spectrum analysis 

due to the effect of ‘‘time’’ is considered. In addition, stresses and deformations in the 

structure are being considered as an initial boundary state for computation of stresses in the 

next step. 

 

Moreover, nonlinearities that usually happen during an earthquake can be included 

in the time history analysis. As for example, nonlinearities cannot be simply incorporated in 

response spectrum analysis. In contrast of the response spectrum method, nonlinear time 

history analysis does not assume exact method for mode combination. Therefore, results 

are realistic and not conservative.  

 

 

 

Figure 4.5: Time history analysis in P-M interaction ratios 
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(a) 

 

 

 

(b) 

 

 

 

(c) 

 

Figure 4.6: Time History graph that obtained from SAP 2000 (a) HGE direction  

      (b) HGN direction (c) HGZ direction. 
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Figure 4.6 (a) shows the time history graph for HGE direction. The maximum 

acceleration is about 1.222 gals and at the time 636.33 sec. While, for the Figure 4.6 (b) 

shows the time history graph for HGN direction. The maximum acceleration is about 1.08 

gals and at the time 893.65 sec. Next, Figure 4.6 (c) shows the time history graph for HGZ 

direction. The maximum acceleration is about 0.96 gals and at the time 1087.63 sec. 

 

4.2.4 Dead Load 

 

           

 

 

 

Figure 4.7: Dead load analysis (a) Critical member in P-M interaction ratios  

        (b) Deformed shape 

 

 

 

(a) (b) 
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4.2.5 Live Load 

 

 

 

Figure 4.8: Live load analysis in P-M interaction ratios 

 

4.2.6 Wave Load 

 

           

 

 

 

Figure 4.9: Wave load analysis (a) Critical member in P-M interaction ratios  

        (b) Deformed shape 

(a) (b) 
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4.2.7 Wind Load 

 

           

 

 

Figure 4.10: Wind load analysis (a) Critical member in P-M interaction ratios  

        (b) Deformed shape 

 

 

 

 

 

 

 

 

 

(a) (b) 
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4.3  ANALYSIS OF SHEAR, MOMENT AND AXIAL FORCE FOR CRITICAL 

MEMBER OF VARIOUS LOADS 

 

4.3.1 Dead Load, DL 

 

The analysis that obtained from SAP 2000 also defines the most critical part for the 

analysis of dead load that is frame 33 of the jacket offshore platform. Figure 4.11 shows the 

shear force is 8.67 kN and the bending moment is 55185.18 kN.mm as shown in Figure 

4.12. While, from the Figure 4.14, the axial force is 6850.43 kN.  

 

 

 

Figure 4.11: Shear force graph for member 33 

 

 

 

Figure 4.12: Bending moment graph for member 33 
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Figure 4.13: Bending moment diagram of offshore platform 

 

 

 

Figure 4.14: Axial force graph for member 33 

 

 

 

Figure 4.15: Axial force diagram of offshore platform 
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4.3.2 Environmental load, EL (Wind+Wave+Current) 

 

The analysis that obtained from SAP 2000 also defines the most critical part for the 

analysis of environmental load which are wind, wave and current that is frame 5 of the 

jacket offshore platform. Figure 4.16 shows the shear force is 6.436x10
-3

 kN and the 

bending moment is 105.32 kN.mm as shown in Figure 4.17. While, from the Figure 4.18, 

the axial force is 3.467 kN.  

 

 

 

Figure 4.16: Shear force graph for frame 5 

 

 

 

Figure 4.17: Bending moment graph for frame 5 

 

 

 

Figure 4.18: Axial force graph for frame 5 
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4.3.3 Response Spectrum, RS 

 

The analysis that obtained from SAP 2000 also defines the most critical part for the 

analysis of response spectrum that is frame 21 of the jacket offshore platform. Figure 4.19 

shows the shear force is 0.019 kN and the bending moment is 152.52 kN.mm as shown in 

Figure 4.20. While, from the Figure 4.21, the axial force is 0.256 kN.  

 

 

 

Figure 4.19: Shear force graph for frame 21 

 

 

 

Figure 4.20: Bending moment graph for frame 21 

 

 

 

Figure 4.21: Axial force graph for frame 21 
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4.3.4 Combination load (Dead Load + Time History + Wind + Wave), 

DL+TH+WI+WA 

 

The analysis that obtained from SAP 2000 also defines the most critical part for the 

analysis of combination of load which are dead load, time history and environmental load 

that is frame 10 of the jacket offshore platform. Figure 4.22 shows the shear force is 78.901 

kN and the bending moment is 730641.06 kN.mm as shown in Figure 4.23. While, from the 

Figure 4.24, the axial force is 252.92 kN.  

 

 
 

Figure 4.22: Shear force graph for frame 10 

 

 
 

Figure 4.23: Bending moment graph for frame 10 

 

 
 

Figure 4.24: Axial force graph for frame 10 
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4.4  SUMMARY OF ANALYSIS 

 

4.4.1 Shear Force and Shear Stress 

 

Table 4.3: Shear force and shear stress for each combination load case 

 

Case Frame 

name 

Design 

shear force, 

VEd (kN) 

Shear 

resistance,Vc,Rd 

(kN) 

Shear 

stress, 

𝝈𝒔(kN/m
2
) 

Allowable shear 

stress, 

𝝈𝒂𝒍𝒍,𝒔(kN/m
2
) 

DL  33 8.67 8085.65 139.84 130413.71 

EL 5 6.436x10
-3 

6501.31 0.129 130548.39 

RS 21 0.019 6501.31 0.382 130548.39 

DL + TH + 

WI + WA 

10 78.901 6501.31 1584.36 130548.39 

 

 
 

Figure 4.25: Shear stress versus various cases 
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The table 4.3 and figure 4.25 shows the shear stress at most critical member of 

jacket offshore platform for the analysis of the various load. All the calculation of the shear 

stress can be obtained in the Appendix B .It shows that the highest value for shear stress is 

1584.36 kN/m
2 

which are the combination of dead load, time history, wind and wave load 

that occurs in frame 10. However, the shear stress is lower than the allowable stress which 

is 130548.39 kN/m
2
. Therefore, the offshore platform can withstand the loading and safe. 

 

4.4.2 Bending Moment and Bending Stress 

 

Table 4.4: Bending moment and bending stress for each combination load case 

 

Case Frame 

name 

Max external 

design moment, 

Med (kN.mm) 

Moment 

resistance, 

Mrd 

(kN.mm) 

Bending 

stress,𝝈𝒃 

(kN/m
2
) 

Allowable 

bending 

stress,𝝈𝒂𝒍𝒍,𝒃 

(kN/m
2
) 

DL  33 55185.18 9208522.5 2127 355000 

EL 5 105.32 4465774.57 8.372 355000 

RS 21 152.52 4465774.57 12.12 355000 

DL + TH + 

WI + WA 

10 730641.06 4465774.57 58081.21 355000 
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Figure 4.26: Bending stress versus various cases 

 

The table 4.4 and figure 4.26 shows the bending stress at most critical member of 

jacket offshore platform for the analysis of the various load. All the calculation of the 

bending stress can be obtained in the Appendix B .It shows that the highest value for 

bending stress is 58081.21 kN/m
2 

which are the combination of dead load, time history, 

wind and wave load that occurs in frame 10. However, the bending stress is lower than the 

allowable bending stress which is 355000 kN/m
2
. Therefore, the offshore platform can 

withstand the loading and safe. 
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4.4.3 Displacement 

 

Table 4.5: Displacement result for various load analysis 

 

Cases U1 (mm) U2 (mm) U3 (mm) 

Dead 4.32 133.36 77.97 

Live 0.15 182.38 23.56 

Free Vibration 2.14 1.94 10.6 

Response Spectrum 0.09 0.04 0.01 

Time History 1.34E-07 2.64E-07 2.74E-08 

Dead+TH+Wind+Wave 0.06 133.34 77.97 

 

 

 

 

Figure 4.27: Displacement graph for various load analysis 
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From the result as shown in table 4.5 and figure 4.27, it shows the maximum 

displacement is 182.38 mm for U2 direction when live load is applied. 

 

4.4.4 Force 

 

Table 4.6: Force result for various load analysis 

 

Cases F1 (kN.mm) F2 (kN.mm) F3 (kN.mm) 

Dead 847.38 1550.52 6850.42 

Free Vibration (FV) 121.00 76.95 171.06 

Time History (TH) 0.0000065 0.0000048 0.000018 

Wave (Wa) 3.995 1.49 5.69 

Wind (Wi) 0.32 0.07 1.03 

Dead+TH+Wind+Wave  848.15 1552.08 6856.67 

 

 

 

 

Figure 4.28: Force graph for various load analysis 
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From the result for the force that obtained as shown in table 4.6 and figure 4.28, the 

maximum force is 6856.67 kN.mm for F3 direction when the combination of dead load, 

time history, wind and wave load is applied. 

 

4.4.5 Moment 

 

Table 4.7: Moment result for various load analysis 

 

Cases M1 (kN.mm) M2 (kN.mm) M3 (kN.mm) 

Wind 0.52 25.54 2.98 

Wave 959.37 558.67 272.68 

Free Vibration 5615.01 4866.04 18850.56 

Time History 0.006478 0.006478 0.000649 

 

 

 

 

Figure 4.29: Moment graph for various load analysis 

 

From the result of bending moment as shown in table 4.7, it gives the maximum 

value is 18850.56 kN.mm when earthquake loading which is free vibration is being applied.



 

 

 

CHAPTER 5 

 

 

CONCLUSIONS AND RECOMMENDATIONS 

 

 

5.1  INTRODUCTION 

 

 Most of the offshore platform in Malaysia is designed without considering of the 

earthquake effects because there are no regulations requiring the structure to be designed 

for earthquake as Malaysia does not lie in any presently demarcated seismic zone. 

However, Malaysia is located close to seismically active plate boundaries which are the 

inter-plate boundary between Eurasian and Philippine Plates on the east. Sabah is the only 

state in Malaysia that exposed to earthquake activities if compared to other parts of 

Malaysia. Recently, an earthquake struck the Ranau, sabah and surrounding areas such as 

Tambunan, Tuaran, Kota Kinabalu and Kota Belud on 5
th

 June 2015, Friday measuring 5.9 

on the Ritcher scale which claiming 18 lives (The Star Online,2015).  

 

Therefore, the significance of the research study is to identify the earthquake ground 

motion due to Philippine earthquake for assessment of offshore platform in Malaysia. The 

analysis of behavior of the offshore platform structures of 3-legged fixed offshore 

structures under the earthquake effect is obtained to develop the earthquake design criteria 
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for the offshore structures that are located in Malaysia region. The related code (API) and 

the computer software of SAP 2000 is used for analysis are very helpful for designing 

offshore structure. 

 

 

 

Figure 5.1: The glass at bank in Ranau Sabah broken due to Ranau earthquake 

 

Source: http://www.astroawani.com/foto-malaysia/gempa-bumi-melanda-ranau-sabah 

2480/bank-di-ranau-27294 

 

http://www.astroawani.com/foto-malaysia/gempa-bumi-melanda-ranau-sabah%202480/bank-di-ranau-27294
http://www.astroawani.com/foto-malaysia/gempa-bumi-melanda-ranau-sabah%202480/bank-di-ranau-27294
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Figure 5.2: The structural column fracture and collapsed due to Ranau earthquake.  

 

Source:  http://www.astroawani.com/foto-malaysia/gempa-bumi-melanda-ranau-sabah-

2480/tiang-rumah-yang-hampir-musnah-27305 

 

5.2 CONCLUSIONS 

 

Based on the finding research, it can be concluded that: 

 

i. This fixed offshore platform is not representing 100% of the actual structure 

because the assumption have been made such that the structure is fixed to the 

ground and the connection which is welded joint is not considered to be designed in 

this research. 

 

http://www.astroawani.com/foto-malaysia/gempa-bumi-melanda-ranau-sabah-2480/tiang-rumah-yang-hampir-musnah-27305
http://www.astroawani.com/foto-malaysia/gempa-bumi-melanda-ranau-sabah-2480/tiang-rumah-yang-hampir-musnah-27305
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ii. The structure can withstand the dead load, live load, environmental load and 

seismic load since the result shows that the maximum shear stress and bending 

stress are lower than allowable capacity check. 

 

iii. The maximum shear stress is 1584.36 kN/m2 which are the combination of dead 

load, time history, wind and wave load that occurs in frame 10.  

 

iv. The highest value for bending stress is 58081.21 kN/m2 which are the combination 

of dead load, time history, wind and wave load that occurs in frame 10. 

 

v. From the result of bending moment, it gives the maximum value is 18850.56 

kN.mm when earthquake loading which is free vibration is being applied 

 

vi. The maximum displacement is 182.38 mm when live load is applied. 

 

vii. From the free vibration analysis, the highest value of natural period is 0.86143s that 

is from mode shape 1. 

 

viii. The analysis of behavior of the offshore platform structures of 3-legged fixed 

offshore structures under the earthquake effect is obtained. 

 

5.3 RECOMMENDATIONS 

 

There are several recommendations that can be made for the further research regarding to 

this topic: 
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i. More analysis to study the column behaviour and soil interaction method should be 

considered.  

 

ii. Improvement to the offshore structure model structure can still be done so that 

actual behaviour of jacket member can be obtained such as the joint connection 

should be model according the designed specification. 

 

iii. The research for this offshore structure can be made for other offshore structure, not 

limited to only for fixed offshore structure. 
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APPENDIX A 

 

OFFSHORE DESIGN STRUCTURE 

 

Wind load 

𝑭 = (
𝝆

𝟐
) 𝒖𝟐 𝑪𝒔𝑨 

𝐹 =  
1.2

2
 𝑥 21.82 𝑥 1.0 𝑥 1.47 

𝐹 = 19.23 𝑁 

Wave load 

𝑭 =  𝑭𝑫 + 𝑭𝑰 =  𝑪𝑫  
𝒘

𝟐𝒈
 𝑨 𝑼 |𝑼| +  𝑪𝒎  

𝒘

𝒈
 𝑽 

𝜹𝑼

𝜹𝒕
  

Smooth 

𝐹 = 0.65 𝑥 
9810

2 𝑥 9.81
 𝑥 1.37 𝑥 0.75 𝑥 |0.75| + 1.6 𝑥 

9810

9.81
 𝑥 

𝜋 𝑥 1.372

4
 𝑥 

0.75

10.9
 

𝐹 = 250.45 + 162.29 

𝐹 = 412.74 
𝑁

𝑚
= 0.413

𝑘𝑁

𝑚
 

Rough 

𝐹 = 1.05 𝑥 
9810

2 𝑥 9.81
 𝑥 1.37 𝑥 0.75 𝑥 |0.75| + 1.2 𝑥 

9810

9.81
 𝑥 

𝜋 𝑥 1.372

4
 𝑥 

0.75

10.9
 

𝐹 = 404.58 + 121.72 

𝐹 = 526.3 
𝑁

𝑚
= 0.526

𝑘𝑁

𝑚
 

Current  

𝑭𝒄 =  𝑭𝑫 =  𝑪𝑫  
𝒘

𝟐𝒈
 𝑨 𝑼 |𝑼| 

𝐹𝑐 = 250.45 
𝑁

𝑚
= 0.25

𝑘𝑁

𝑚
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APPENDIX B 

 

CALCULATION FOR CRITICAL MEMBER  

 

DEAD LOAD: FRAME 33 

Shear Resistance, Vc,Rd 

i) Maximum external design shear force, VEd = 8.670 kN 

ii) Shear resistance, Vc,Rd = Vpl,Rd  

Where, 𝑉𝑝𝑙,𝑅𝑑 =  
𝐴𝑣  (

𝑓𝑦

√3
)

𝛾𝑚0
 

From SAP 2000 computer software,  

Shear Area, Av = 39450 mm
2
, fy = 355 N/mm

2
, γm0 = 1 

𝑉𝑝𝑙,𝑅𝑑 =  

39450 (
355

√3
)

1
 

𝑉𝑝𝑙,𝑅𝑑 = 8085.65 𝑘𝑁 

iii) Design Check, 

𝑉𝐸𝑑

𝑉𝑐,𝑅𝑑
=  

8.670

8085.65
= 0.0011 ≤ 1.0 , the section is satisfactory. 

From SAP 2000 computer software,  

Area, Ac = 61967.915 mm
2
 

Shear Stress, 𝜎𝑠 =  
𝑉𝐸𝑑

𝐴𝑐
=  

8.670

0.062
= 139.84 

𝑘𝑁

𝑚2 

Allowable Shear Stress, 𝜎𝑎𝑙𝑙,𝑠 =  
𝑉𝑐,𝑅𝑑

𝐴𝑐
=  

8085.65

0.062
= 130413.71 

𝑘𝑁

𝑚2 
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Therefore, 𝜎𝑠 ≤  𝜎𝑎𝑙𝑙,𝑠, the section is satisfactory. 

The shear stress is 139.84 kN/m
2
, while the allowable shear stress is 130413.71 kN/m

2
. 

Bending Moment Resistance, Mc,Rd 

i) Maximum external design shear force, MEd = 55185.18 kN.mm 

ii) Moment resistance, Mc,Rd = Mpl,Rd  

Where, 𝑀𝑝𝑙,𝑅𝑑 =  
𝑊𝑝𝑙  (𝑓𝑦)

𝛾𝑚0
 

From SAP 2000 computer software,  

Wpl = 25939500.00 mm
3
, fy = 355 N/mm

2
, γm0 = 1 

𝑀𝑝𝑙,𝑅𝑑 =  
  25939500.00(355)

1
 

𝑀𝑝𝑙,𝑅𝑑 = 9208522.5 𝑘𝑁. 𝑚𝑚 

iii) Design Check, 

𝑀𝐸𝑑

𝑀𝑐,𝑅𝑑
=  

55185.18

9208522.5
= 0.006 ≤ 1.0 , the section is satisfactory. 

From SAP 2000 computer software,  

Section modulus, Sx = 25939500.00 mm
3
 

Bending Stress, 𝜎𝑏 =  
𝑀𝐸𝑑

𝑆𝑥
=  

55185.18

25939500.00
= 2.127𝑥10−3  

𝑘𝑁

𝑚𝑚2 = 2127
𝑘𝑁

𝑚2  

Allowable Bending Stress, 𝜎𝑎𝑙𝑙,𝑏 =  
𝑀𝑐,𝑅𝑑

𝑆𝑥
=  

9208522.5 

25939500.00
= 0.355 

𝑘𝑁

𝑚𝑚2 = 355000
𝑘𝑁

𝑚2   

Therefore, 𝜎𝑏 ≤  𝜎𝑎𝑙𝑙,𝑏, the section is satisfactory. 

The bending stress is 2127 kN/m
2
, while the allowable bending stress is 355000 kN/m

2
. 
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ENVIRONMENTAL LOAD (WIND + WAVE): FRAME 5 

Shear Resistance, Vc,Rd 

i) Maximum external design shear force, VEd = 6.436x10
-3

 kN 

ii) Shear resistance, Vc,Rd = Vpl,Rd  

Where, 𝑉𝑝𝑙,𝑅𝑑 =  
𝐴𝑣  (

𝑓𝑦

√3
)

𝛾𝑚0
 

From SAP 2000 computer software,  

Shear Area, Av = 31720 mm
2
, fy = 355 N/mm

2
, γm0 = 1 

𝑉𝑝𝑙,𝑅𝑑 =  

31720 (
355

√3
)

1
 

𝑉𝑝𝑙,𝑅𝑑 = 6501.31 𝑘𝑁 

iii) Design Check, 

𝑉𝐸𝑑

𝑉𝑐,𝑅𝑑
=  

6.436x10−3

6501.31
= 0.000001 ≤ 1.0 , the section is satisfactory. 

From SAP 2000 computer software,  

Area, Ac = 49825.66 mm
2
 

Shear Stress, 𝜎𝑠 =  
𝑉𝐸𝑑

𝐴𝑐
=  

6.436x10−3 

0.0498
= 0.129 

𝑘𝑁

𝑚2 

Allowable Shear Stress, 𝜎𝑎𝑙𝑙,𝑠 =  
𝑉𝑐,𝑅𝑑

𝐴𝑐
=  

6501.31

0.0498
= 130548.39 

𝑘𝑁

𝑚2 

Therefore, 𝜎𝑠 ≤  𝜎𝑎𝑙𝑙,𝑠, the section is satisfactory. 

The shear stress is 0.129 kN/m
2
, while the allowable shear stress is 130548.39 kN/m

2
. 
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Bending Moment Resistance, Mc,Rd 

i) Maximum external design shear force, MEd = 105.32 kN.mm 

ii) Moment resistance, Mc,Rd = Mpl,Rd  

Where, 𝑀𝑝𝑙,𝑅𝑑 =  
𝑊𝑝𝑙  (𝑓𝑦)

𝛾𝑚0
 

From SAP 2000 computer software,  

Wpl = 12579646.67 mm
3
, fy = 355 N/mm

2
, γm0 = 1 

𝑀𝑝𝑙,𝑅𝑑 =  
  12579646.67(355)

1
 

𝑀𝑝𝑙,𝑅𝑑 = 4465774.57 𝑘𝑁. 𝑚𝑚 

iii) Design Check, 

𝑀𝐸𝑑

𝑀𝑐,𝑅𝑑
=  

105.32 

4465774.57
= 0.000024 ≤ 1.0 , the section is satisfactory. 

From SAP 2000 computer software,  

Section modulus, Sx = 12579646.67 mm
3
 

Bending Stress, 𝜎𝑏 =  
𝑀𝐸𝑑

𝑆𝑥
=  

105.32 

12579646.67 
= 8.372𝑥10−6  

𝑘𝑁

𝑚𝑚2 = 8.372
𝑘𝑁

𝑚2  

Allowable Bending Stress, 𝜎𝑎𝑙𝑙,𝑏 =  
𝑀𝑐,𝑅𝑑

𝑆𝑥
=  

4465774.57 

12579646.67
= 0.355 

𝑘𝑁

𝑚𝑚2 = 355000
𝑘𝑁

𝑚2   

Therefore, 𝜎𝑏 ≤  𝜎𝑎𝑙𝑙,𝑏, the section is satisfactory. 

The bending stress is 8.372 kN/m
2
, while the allowable bending stress is 355000 kN/m

2 

.  
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RESPONSE SPECTRUM: FRAME 21 

Shear Resistance, Vc,Rd 

i) Maximum external design shear force, VEd = 0.019 kN 

ii) Shear resistance, Vc,Rd = Vpl,Rd  

Where, 𝑉𝑝𝑙,𝑅𝑑 =  
𝐴𝑣  (

𝑓𝑦

√3
)

𝛾𝑚0
 

From SAP 2000 computer software,  

Shear Area, Av = 31720 mm
2
, fy = 355 N/mm

2
, γm0 = 1 

𝑉𝑝𝑙,𝑅𝑑 =  

31720(
355

√3
)

1
 

𝑉𝑝𝑙,𝑅𝑑 = 6501.31 𝑘𝑁 

iii) Design Check, 

𝑉𝐸𝑑

𝑉𝑐,𝑅𝑑
=  

0.019

6501.31
= 0.0000029 ≤ 1.0 , the section is satisfactory. 

From SAP 2000 computer software,  

Area, Ac = 49825.66 mm
2
 

Shear Stress, 𝜎𝑠 =  
𝑉𝐸𝑑

𝐴𝑐
=  

0.019

0.0498
= 0.382 

𝑘𝑁

𝑚2 

Allowable Shear Stress, 𝜎𝑎𝑙𝑙,𝑠 =  
𝑉𝑐,𝑅𝑑

𝐴𝑐
=  

6501.31

0.0498
= 130548.39 

𝑘𝑁

𝑚2 

Therefore, 𝜎𝑠 ≤  𝜎𝑎𝑙𝑙,𝑠, the section is satisfactory. 

The shear stress is 0.382 kN/m
2
, while the allowable shear stress is 130548.39 kN/m

2
. 
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Bending Moment Resistance, Mc,Rd 

i) Maximum external design shear force, MEd = 152.52 kN.mm 

ii) Moment resistance, Mc,Rd = Mpl,Rd  

Where, 𝑀𝑝𝑙,𝑅𝑑 =  
𝑊𝑝𝑙  (𝑓𝑦)

𝛾𝑚0
 

From SAP 2000 computer software,  

Wpl = 12579646.67 mm
3
, fy = 355 N/mm

2
, γm0 = 1 

𝑀𝑝𝑙,𝑅𝑑 =  
  12579646.67(355)

1
 

𝑀𝑝𝑙,𝑅𝑑 = 4465774.57 𝑘𝑁. 𝑚𝑚 

iii) Design Check, 

𝑀𝐸𝑑

𝑀𝑐,𝑅𝑑
=  

152.52 

4465774.57
= 0.000034 ≤ 1.0 , the section is satisfactory. 

From SAP 2000 computer software,  

Section modulus, Sx = 12579646.67 mm
3
 

Bending Stress, 𝜎𝑏 =  
𝑀𝐸𝑑

𝑆𝑥
=  

152.52

12579646.67 
= 12.12𝑥10−6  

𝑘𝑁

𝑚𝑚2 = 12.12
𝑘𝑁

𝑚2  

Allowable Bending Stress, 𝜎𝑎𝑙𝑙,𝑏 =  
𝑀𝑐,𝑅𝑑

𝑆𝑥
=  

4465774.57 

12579646.67
= 0.355 

𝑘𝑁

𝑚𝑚2 = 355000
𝑘𝑁

𝑚2   

Therefore, 𝜎𝑏 ≤  𝜎𝑎𝑙𝑙,𝑏, the section is satisfactory. 

The bending stress is 12.12 kN/m
2
, while the allowable bending stress is 355000 kN/m

2
.  
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COMBINATION OF (DEAD LOAD + TIME HISTORY + WIND + WAVE): 

FRAME 10 

Shear Resistance, Vc,Rd 

i) Maximum external design shear force, VEd = 78.901 kN 

ii) Shear resistance, Vc,Rd = Vpl,Rd  

Where, 𝑉𝑝𝑙,𝑅𝑑 =  
𝐴𝑣  (

𝑓𝑦

√3
)

𝛾𝑚0
 

From SAP 2000 computer software,  

Shear Area, Av = 31720 mm
2
, fy = 355 N/mm

2
, γm0 = 1 

𝑉𝑝𝑙,𝑅𝑑 =  

31720(
355

√3
)

1
 

𝑉𝑝𝑙,𝑅𝑑 = 6501.31 𝑘𝑁 

iii) Design Check, 

𝑉𝐸𝑑

𝑉𝑐,𝑅𝑑
=  

78.901

6501.31
= 0.0121 ≤ 1.0 , the section is satisfactory. 

From SAP 2000 computer software,  

Area, Ac = 49825.66 mm
2
 

Shear Stress, 𝜎𝑠 =  
𝑉𝐸𝑑

𝐴𝑐
=  

78.901

0.0498
= 1584.36 

𝑘𝑁

𝑚2 

Allowable Shear Stress, 𝜎𝑎𝑙𝑙,𝑠 =  
𝑉𝑐,𝑅𝑑

𝐴𝑐
=  

6501.31

0.0498
= 130548.39 

𝑘𝑁

𝑚2 

Therefore, 𝜎𝑠 ≤  𝜎𝑎𝑙𝑙,𝑠, the section is satisfactory. 

The shear stress is 1584.36 kN/m
2
, while the allowable shear stress is 130548.39 kN/m

2
. 
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Bending Moment Resistance, Mc,Rd 

i) Maximum external design shear force, MEd = 730641.06 kN.mm 

ii) Moment resistance, Mc,Rd = Mpl,Rd  

Where, 𝑀𝑝𝑙,𝑅𝑑 =  
𝑊𝑝𝑙  (𝑓𝑦)

𝛾𝑚0
 

From SAP 2000 computer software,  

Wpl = 12579646.67 mm
3
, fy = 355 N/mm

2
, γm0 = 1 

𝑀𝑝𝑙,𝑅𝑑 =  
  12579646.67(355)

1
 

𝑀𝑝𝑙,𝑅𝑑 = 4465774.57 𝑘𝑁. 𝑚𝑚 

iii) Design Check, 

𝑀𝐸𝑑

𝑀𝑐,𝑅𝑑
=  

730641.06  

4465774.57
= 0.164 ≤ 1.0 , the section is satisfactory. 

From SAP 2000 computer software,  

Section modulus, Sx = 12579646.67 mm
3
 

Bending Stress, 𝜎𝑏 =  
𝑀𝐸𝑑

𝑆𝑥
=  

730641.06

12579646.67 
= 58081.21𝑥10−6  

𝑘𝑁

𝑚𝑚2 = 58081.21
𝑘𝑁

𝑚2  

Allowable Bending Stress, 𝜎𝑎𝑙𝑙,𝑏 =  
𝑀𝑐,𝑅𝑑

𝑆𝑥
=  

4465774.57 

12579646.67
= 0.355 

𝑘𝑁

𝑚𝑚2 = 355000
𝑘𝑁

𝑚2   

Therefore, 𝜎𝑏 ≤  𝜎𝑎𝑙𝑙,𝑏, the section is satisfactory. 

The bending stress is 58081.21 kN/m
2
, while the allowable bending stress is 355000 kN/m

2 
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APPENDIX C 

 

TABLE OF STIFFNESS AND MASS 

 

Table 3.7: Stiffness and mass for horizontal member 

 

No. Level 

Length  

(mm) 

Modulus of 

Elasticity, 

E (N/mm2) 

Outside 

diameter, 

do (mm) 

Inside 

diameter, 

di (mm) 

Moment of  

Inertia, I 

(mm^4) 

Stiffness,  

k 

Density, 

(kg/m^3) 

Volume, 

(m^3) 

Mass, 

(kg) 

1 1 34385 210000 813 20 21448070576 1.3099E+11 7489 17.8416 133615.6 

2 1 30775 210000 813 20 21448070576 1.46356E+11 7489 15.9684 119587.6 

3 1 30774 210000 813 20 21448070576 1.4636E+11 7489 15.9679 119583.7 

4 1 15387 210000 813 20 21448070576 2.92721E+11 7489 7.98396 59791.87 

5 1 15387 210000 813 20 21448070576 2.92721E+11 7489 7.98396 59791.87 

6 1 17192 210000 813 20 21448070576 2.61988E+11 7489 8.92053 66805.87 

7 1 8570 210000 813 20 21448070576 5.25565E+11 7489 4.44678 33301.9 

8 2 28150 210000 813 20 21448070576 1.60003E+11 7489 14.6064 109387.2 

9 2 25937 210000 813 20 21448070576 1.73655E+11 7489 13.4581 100787.8 

10 2 25937 210000 813 20 21448070576 1.73655E+11 7489 13.4581 100787.8 

11 2 12969 210000 813 20 21448070576 3.47297E+11 7489 6.72932 50395.84 

12 2 12969 210000 813 20 21448070576 3.47297E+11 7489 6.72932 50395.84 

13 2 14075 210000 813 20 21448070576 3.20007E+11 7489 7.30319 54693.61 

14 2 7056 210000 813 20 21448070576 6.38335E+11 7489 3.6612 27418.7 



103 
 

Table 3.7: Continued 

 

No. Level 

Length  

(mm) 

Modulus of 

Elasticity, 

E (N/mm2) 

Outside 

diameter, 

do (mm) 

Inside 

diameter, 

di (mm) 

Moment of  

Inertia, I 

(mm^4) 

Stiffness,  

k 

Density, 

(kg/m^3) 

Volume, 

(m^3) 

Mass, 

(kg) 

15 3 22954 210000 813 20 21448070576 1.96223E+11 7489 11.9103 89196.25 

16 3 21907 210000 813 20 21448070576 2.05601E+11 7489 11.367 85127.74 

17 3 21907 210000 813 20 21448070576 2.05601E+11 7489 11.367 85127.74 

18 3 10953 210000 813 20 21448070576 4.1122E+11 7489 5.68326 42561.93 

19 3 10953 210000 813 20 21448070576 4.1122E+11 7489 5.68326 42561.93 

20 3 11476 210000 813 20 21448070576 3.9248E+11 7489 5.95463 44594.24 

21 3 5738 210000 813 20 21448070576 7.84959E+11 7489 2.97732 22297.12 

22 4 19242 210000 813 20 21448070576 2.34076E+11 7489 9.98423 74771.9 

23 4 19053 210000 813 20 21448070576 2.36398E+11 7489 9.88616 74037.47 

24 4 19053 210000 813 20 21448070576 2.36398E+11 7489 9.88616 74037.47 

25 4 9526 210000 813 20 21448070576 4.72821E+11 7489 4.94282 37016.79 

26 4 9526 210000 813 20 21448070576 4.72821E+11 7489 4.94282 37016.79 

27 4 9621 210000 813 20 21448070576 4.68152E+11 7489 4.99212 37385.95 

      

TOTAL 8.68492E+12 

  

1832079 
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Table 3.8: Stiffness and mass for vertical member 

 

No. Level 

Length  

(mm) 

Modulus of 

Elasticity, 

E (N/mm2) 

Outside 

diameter, 

do (mm) 

Inside 

diameter, 

di (mm) 

Moment of  

Inertia, I 

(mm^4) 

Stiffness,  

k 

Density, 

(kg/m^3) 

Volume, 

(m^3) 

Mass, 

(kg) 

1 1 25460 210000 1330 15 1.53615E+11 2.4286332 7489 35.3714 264897 

2 1 25460 210000 1330 15 1.53615E+11 2.4286332 7489 35.3714 264897 

3 1 25269 210000 1330 15 1.53615E+11 2.4285488 7489 35.1061 262909 

4 1 28925 210000 813 20 21448070576 1.557E+11 7489 15.0085 112399 

5 1 28925 210000 813 20 21448070576 1.557E+11 7489 15.0085 112399 

6 1 27995 210000 813 20 21448070576 1.609E+11 7489 14.526 108785 

7 1 28768 210000 813 20 21448070576 1.566E+11 7489 14.9271 111789 

8 1 27995 210000 813 20 21448070576 1.609E+11 7489 14.526 108785 

9 1 28768 210000 813 20 21448070576 1.566E+11 7489 14.9271 111789 

10 2 21218 210000 1330 15 1.53615E+11 2.9141766 7489 29.478 220761 

11 2 21218 210000 1330 15 1.53615E+11 2.9141766 7489 29.478 220761 

12 2 21058 210000 1330 15 1.53615E+11 2.9141894 7489 29.2558 219096 

13 2 33111 210000 813 30 21448038665 1.36E+11 7489 17.1675 128568 

14 2 32374 210000 813 30 21448038665 1.391E+11 7489 16.7854 125706 

15 2 31332 210000 813 30 21448038665 1.438E+11 7489 16.2451 121660 

16 3 15155 210000 1370 35 1.72945E+11 4.0800396 7489 22.3285 167218 

17 3 15155 210000 1370 35 1.72945E+11 4.0800396 7489 22.3285 167218 

18 3 15040 210000 1370 35 1.72945E+11 4.0802527 7489 22.1591 165949 

19 3 25910 210000 813 20 21448070576 1.738E+11 7489 13.4441 100683 

20 3 25784 210000 813 20 21448070576 1.747E+11 7489 13.3787 100193 

21 3 25013 210000 813 20 21448070576 1.801E+11 7489 12.9787 97197.3 

      

TOTAL 1.894E+12 

  

3293659 
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Table 3.9: Summary of total stiffness and mass 

 

MEMBER  Stiffness, k Mass (kg) 

HORIZONTAL 8.6849*10^12 1832078.7 

VERTICAL 1.894*10^12 3293659 

TOTAL 10.5789*10^12 5125737.7 
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APPENDIX D 

 

FREE VIBRATION ANALYSIS (LIST OF MODE SHAPE) 

 

          

 

 

 

             

 

 

 

Figure 4.29: Deformed shape for (a) mode 5 (b) mode 6 (c) mode 7 (d) mode 8 

       (e) mode 9 (f) mode 10 (g) mode 11 (h) mode 12 

 

(a) (b) (c) (d) 

(e) (f) (g) (h) 


